95 D1 stalling

XCELLER8

Well-known member
Sep 21, 2009
204
0
as Tugela was refering to.....there is a small fuel pump wiring harness that has a connector which is located next to the fuel tank and is accessable over the driver's side rear frame rail....it's only a couple feet long...follow it back from the pump.........these are KNOWN to be an ass ache.....the weather proof connectors aint so weatherproof, the same harness has the fuel gauge wires in it too.....check it out......personal experience on 2 of my discos
 

Donno

Member
Callsign: VE7NEV
Mar 7, 2015
20
1
Sechelt, BC
So I think I've been dealing with multiple problems. Finally picked up a fuel pressure tester and low and behold, no pressure even when i jump the pump directly with 12v. I know, I need to start listening to you guys, right?

Picked up a replacement pump and installed yesterday, have pressure, yay! Started up again for about 30 seconds and died! WTF!

Went back through checking everything, put the timing light on and no spark. Rechecked all connections, one to the amp was loose. Getting a sporadic spark now with timing gun on the coil wire. I think it should be flashing constantly, correct?

Gonna try and pick up a new coil now. Everything else checks out so far unless their's other suggestions.

Cheers
 

Donno

Member
Callsign: VE7NEV
Mar 7, 2015
20
1
Sechelt, BC
Got the spark issue figured; loose connection/broken wire at the coil and ignition amplifier. Now back to original symptoms. Was able to track down a 14CUX ECU today and installed. Fired right up and ran for a good 10 minute drive! Yeah, figured it out. Gave the ECM back and now on the hunt for one that won't break the bank. Have a few local leads.

Problem solved! Thanks everyone with the advice.
 
Reactions: p m