Compressor Issues: C1A20

Howski

Well-known member
Oct 19, 2009
960
14
Greenville, S.C.
Have been having issues with the compressor running a long time, and often, with an occasional ‘normal height only’ fault. The run time and fault frequency has increased and was able to pin it down to code C1A20. Ran live data but it shows strong gallery pressure (250psi) although it does get hot pretty quick. Know this code often means compressor going to crap but the good gallery pressure raised a flag. Replaced the dryer back in the spring and the old dryer material was in bad shape. Have also checked for any leaks at air springs, valve blocks and compressor. Truck doesn’t drop overnight either. Anything else worth investigating before I pull the trigger on a compressor? Clogged valve block, compressor filter or air line?
 

Attachments

Last edited:

jymmiejamz

Well-known member
Callsign: KN4JHI
Dec 5, 2004
5,464
44
31
Los Angeles, Ca
More than likely it is the compressor, but it could also be the reservoir itself leaking. The leaks are often pretty hard to spot. If you have a Hitachi compressor currently, I would go ahead and replace with an AMK compressor. They are far more reliable and also much quieter. Even if that is not your problem, it is a worthwhile upgrade.
 

Howski

Well-known member
Oct 19, 2009
960
14
Greenville, S.C.
Thanks Jimmy. I also noticed the gallery pressure gets very low (13 psi) after resting for awhile. The pressure is higher after the compressor stops but continues to lower down to what is essentially atmospheric pressure. Could this be the case if it was a leaky reservoir? Guess I’m not exactly where in the flow of air the pressure sensor is