knocking

Trent and his Rover

Well-known member
Jun 25, 2006
124
1
Our D1 needing rebuilding due to her knocking and jerking ride. After her rebuild her knocking and jerking continued. And I don't know why.

The rebuild included the following new items:
  • new timing chain & gears
  • gear drive
  • new dizzy
  • lifters
  • con rod bearings
  • new main bearings
  • rings
  • complete exhaust system.
On the road she jerks in gear like she's missing. No codes are present. 2000 rpm idle seems to eliminate the knocking but the new exhaust system is a loud flowmaster so it is difficult to hear. So..... there aren't many things left to consider replacing. Appreciate your thoughts and thanks, -Trent
 

Trent and his Rover

Well-known member
Jun 25, 2006
124
1
Anyone here ever try a lifter install without removing the heads? Anyhow, my son suggested using Seafoam in both the tank and intake because the knocking reminded him of a bad lifter. I did install new ones but perhaps one was somehow bad and didn't take to its oil pre-soaking or perhaps some debris got into the system? ....No clue. Seafoamed up, she barely blew any smoke as her engine was previously cleaned out during her rebuild. However funny enough, I think the Seafoam did make her drive a little better (somehow) but the knocking continued regardless. My next step is to once again replace her lifters. Anyone here ever try a lifter install without removing the heads? Not sure if that's possible as I've always removed heads.
 

mearstrae

Well-known member
Mar 15, 2017
118
11
Pennsylvania
Can't be sure what you mean by "Knocking". If the bearings were not checked at install with Plasti-Gage, for proper clearance, there might be a problem there. You shouldn't soak lifters before installation, cam break in lube should be used (new lifters on an old cam cam can also cause trouble). Seems the only thing you didn't change was the cam, and these can go wrong since most motor oils don't contain Zinc (ZDDP), a must for flat tappet cams. So, since this problem hasn't changed after the re-build I don't believe the lifters are at fault. But, if you want to change lifters out (and check the cam) pull the intake, valve covers, rocker shafts and push rods. There should be room to pull the lifters out. I'd check the fuel delivery and ignition spark before proceeding, easy stuff first. All Seafoam might have done is clean the injectors, since I take it the heads and pistons were already clean. Hard to offer good help at such a distance over the I-net.
 

JohnB

Well-known member
Oct 18, 2007
2,282
8
Oregon
Also agree problems will result with new lifters on a used cam especially if you did not break them in. I would pull the oil filter off and cut it open and inspect for metal as when the cam and lifters go you will find them in the filter.
Other than that I remember a thread years ago about an oil pan that the rods were hitting for some reason but doubt that's your problem.
 

discostew

Well-known member
Sep 14, 2010
6,417
497
Northern Illinois
Yes it did. I forgot about that. Wasn't there some kind of plate we bolted to the front of the thing? I try to forget all distributor related shittery.
It's called CUX but it's pronounce sucks.
 

roverover

Well-known member
Feb 27, 2005
3,799
22
66
Lancaster PA
www.UsedLandRoverParts.com
Same I've had a few D1s in recently all kinds of things I used to know but had to dig up again

Yes we are thinking building a dizzy truck but using a GEMs block but still may just go all GEMs to eliminate that added bit of possible misery