DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
Old 10-04-2017, 06:27 PM   #1
boxster
Member
 
Join Date: Jun 2009
Posts: 69
Default 97 D1 stalls out

My D1 has 305k Miles also has intermittent ignition cut out, with a code P0102, cleaned MAF correctly, checked wiring and vacuum leaks looks ok, also read in the posts that VSS could produce this symptom while driving. I replaced the sensor however problem still there. I also read that faulty fuel pump relay is a pontential. Test drive showed no recurring codes however left stopped for two hours went to re start and noticed black smoke then stall and hesitation then smoothed out. Ran well for another hour then stopped went restart idled and then shut off. Going to try relays never been changed see if it’s that simple! Any ideas are always appreciated!Boxster

Last edited by boxster; 10-04-2017 at 06:54 PM.
boxster is offline   Reply With Quote
Old 10-04-2017, 11:09 PM   #2
XCELLER8
Member
 
Join Date: Sep 2009
Posts: 179
Default Re: 97 D1 stalls out

is your 97 an "advanced evap" equippped truck ?
__________________
95 D1
96 D1
98D1
'00 D2
'03 freelander
XCELLER8 is offline   Reply With Quote
Old 10-04-2017, 11:30 PM   #3
boxster
Member
 
Join Date: Jun 2009
Posts: 69
Default Re: 97 D1 stalls out

Yes
boxster is offline   Reply With Quote
Old 10-04-2017, 11:34 PM   #4
boxster
Member
 
Join Date: Jun 2009
Posts: 69
Default Re: 97 D1 stalls out

Is there something emissions related? Or the EVAP system?
boxster is offline   Reply With Quote
Old 10-06-2017, 12:57 PM   #5
p m
Administrator
 
Join Date: Apr 2004
Location: La Jolla, CA
Posts: 13,735
Default Re: 97 D1 stalls out

P0102 is low signal from MAF sensor. You need to either verify it with any OBD-2 live data scanner, or substitute a known-good sensor. For whatever it's worth - here's a new MAF sensor for forty bucks.


It can be an issue with wiring as well - if a known-good sensor still produces the same results, you need to look in the harness all the way to the ECU connector. "Looks good" may be insufficient.

You can check the fuel rail pressure using the Schrader valve on the passenger side of the fuel rail - you can either make your tester using some 1/8" NPT hardware and a pressure gauge, or buy a kit on Amazon.
It won't help you to troubleshoot an intermittent loss of power at the pump - so you need to dig in and clean up the contacts on the pump connector itself and in the harness connector somewhere near the right rear wheelwell (that one is rarely touched, but it is exposed to moisture and dirt).
__________________
There is a fine line between being an idiot and thinking outside the box with a touch of apathy - RobertF
p m is offline   Reply With Quote
Old 10-06-2017, 10:55 PM   #6
XCELLER8
Member
 
Join Date: Sep 2009
Posts: 179
Default Re: 97 D1 stalls out

Quote:
Originally Posted by boxster View Post
Is there something emissions related? Or the EVAP system?
a couple of possibiliies

the advanced evap models have a trouble prone fuel tank pressure sensor..( mounted to the fuel pump assy)...this pain in the ass device shares its wiring with the TPS and IACV ....which tends to really mess with the fuel / air mixture when it fails, and doesnt necessarrily give a good "code". several of us have had this happen, and while it may not be your issue it may be worth checking on >>you can try unplugging the sensor at the top of the fuel pump assy...

also unhook the battery and then remove the ECU it's also common to find that water has gotten into the ecu and is shorting out any number of things....and causing an intermittent stall.....personal experience
__________________
95 D1
96 D1
98D1
'00 D2
'03 freelander
XCELLER8 is offline   Reply With Quote
Old 10-07-2017, 11:39 AM   #7
boxster
Member
 
Join Date: Jun 2009
Posts: 69
Default Re: 97 D1 stalls out

Thanks, for the info
boxster is offline   Reply With Quote
Old 10-11-2017, 07:25 PM   #8
boxster
Member
 
Join Date: Jun 2009
Posts: 69
Default Re: 97 D1 stalls out

Stall out solved! Replaced MAF with new unit, cleared p0102 code, cold start perfect,test drove no stall out, hot restart no problem, all is well. ����
boxster is offline   Reply With Quote
Old 10-12-2017, 07:57 AM   #9
WaltNYC
Member
 
WaltNYC's Avatar
 
Join Date: Mar 2010
Location: NYC
Posts: 314
Member Trucks
Default Re: 97 D1 stalls out

That is cool. My truck has half the miles as yours but I hope to get there!
__________________
1997 Discovery I SE - 145k miles

RAVE in pdf:
https://drive.google.com/open?id=0By...FdyX1VQMS1iN00
Discovery I exploded parts diagrams....
http://www.allbrit.de/NAV.cfm?SPRACHE=EN&PAGE=491338
WaltNYC is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
D1 stalls in heat robert freye Discovery - Technical Discussions 1 10-09-2014 09:19 AM
D1 Stalls When Hot tedhass Discovery - Technical Discussions 1 03-12-2011 09:29 PM
'96 4.6 stalls after warm up Pasatiempo Range Rover - Technical Discussions 8 09-23-2008 03:16 PM
DII will not idle/stalls out NorCalRC51 Discovery - Technical Discussions 3 10-09-2006 01:20 PM
RRC stalls karover Range Rover - Technical Discussions 6 08-01-2006 09:43 PM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
F18Guy (48)
Discrover (48)
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 04:18 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.