DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
  #201  
Old 03-31-2018, 01:06 AM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
I cant get the /dev/tty* to search. I get a 'Permission Denied" prompt every time. Of course my scan gauge isn't the bluetooth one but I dont know if that matters. Im trying to run it off one of my MacBooks with High Sierra but I have another one that runs Yosemite that im gonna try tomorrow. Ill post some screenshots of what I get tomorrow.
Reply With Quote
  #202  
Old 03-31-2018, 02:00 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
try sudo ls /dev/tty*

You may need to try running the program with sudo in front of it. I'm not much of a mac guy. It was written in linux and compiled on a mac. It ran on my mac mini and thats pretty much where I left it.
Reply With Quote
  #203  
Old 03-31-2018, 01:08 PM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
so with sudo /dev/tty.* i get 'command not found
with sudo ./GEMS /dev/tty* the ./GEMS command not found
and then running the command file you posted i get
logout
Saving session...
...copying shared history...
...saving history...truncating history files...
...completed.

[Process completed]

This is all on High Sierra im about to try it on Yosemite once that laptop charges
Reply With Quote
  #204  
Old 03-31-2018, 01:18 PM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
Same exact thing on the other laptop. I keep getting ./GEMS no such file or directory
Reply With Quote
  #205  
Old 03-31-2018, 01:25 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
you are leaving out the ls command between sudo and the path
Reply With Quote
  #206  
Old 03-31-2018, 01:45 PM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
heres what im getting, tried it a whole bunch of ways


Reids-MacBook-Pro:~ Reid$ sudo is /dev/tty.*
Password:
sudo: is: command not found
Reids-MacBook-Pro:~ Reid$ sudois /dev/tty*
-bash: sudois: command not found
Reids-MacBook-Pro:~ Reid$ sudo is /dev/tty*
sudo: is: command not found
Reids-MacBook-Pro:~ Reid$ sudo Is /dev/tty*
sudo: Is: command not found
Reids-MacBook-Pro:~ Reid$ sudo is /dev/tty.
sudo: is: command not found
Reids-MacBook-Pro:~ Reid$ sudo is /dev/tty.*
sudo: is: command not found
Reids-MacBook-Pro:~ Reid$
Reply With Quote
  #207  
Old 03-31-2018, 01:55 PM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
Okay update I set the gems file to file directory and did ./Gems /dev/tty.*
Its trying to connect to incoming bluetooth port but my Scangauge is usb
Reply With Quote
  #208  
Old 03-31-2018, 09:01 PM
discostew discostew is offline
Member
 
Join Date: Sep 2010
Location: Northern Illinois
Posts: 4,401
I know nothing about the code you guys are talking. But I was wondering if you have ever researched what goes on in the coms interface that must be between the laptop and the vehicle. The actual T4 software never hooks directly to the vehicle.
Reply With Quote
  #209  
Old 03-31-2018, 10:22 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Quote:
Originally Posted by discostew View Post
I know nothing about the code you guys are talking. But I was wondering if you have ever researched what goes on in the coms interface that must be between the laptop and the vehicle. The actual T4 software never hooks directly to the vehicle.
No, but I could guess. Its just like the elm obd2 adapters. It takes very tedious real time communications and makes it more generic so a scheduled event operating system like windows can play.

tx disco that command is LS but lower case. Looks like you are typing an i don't put a '.' between the * The * is a wildcard, it lists all the devices attached and when you find out what it is calling the USB port then you use that in the command line. I know its incredibly user unfriendly, but free stuff usually sucks.
Reply With Quote
  #210  
Old 04-02-2018, 08:14 PM
txdisco1 txdisco1 is offline
Junior Member
 
Join Date: Feb 2018
Location: Texas
Posts: 7
robertf you're right. I was doing IS instead of LS. I found the right USB serial port. It just wont connect now which is funny because when I tried to use a AutoLogic machine to reset the values it wouldn't connect either. So now Ive got a problem with the Rover itself. It will talk to a T4 machine all day but I cant reset the values through that. Weird.
Reply With Quote
  #211  
Old 04-09-2018, 02:42 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
It was too cold to go outside this weekend so I took a look at it, what a mess

I see the problem and a fix is on the way in windows/linux/mac flavors hopefully in the next day or two. I defaulted to a different baud rate than the SX cable can use since Im using a bluetooth module. They don't really care what speed youre using since its not really rs232 between the pc and device. Ended up rewriting almost all of it in C++ so it'll be easier to add a GUI. The rewrite now searches for the adapter so no more command line junk. Once thats up I'll add alarm synch and the auto/manual transmission change option. Should save a couple of p38s from the wrecker with the synch feature.
Reply With Quote
  #212  
Old 04-13-2018, 03:10 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Version 2. Windows only for now, maybe apple next week, maybe not

Requires the SX USB cable (https://www.scantool.net/obdlink-sx/) Bluetooth is broken for now.

Should be self explanatory. Open it up, choose your options, and click go. If you don't select anything and click go it will still poll the ECU, gain maintenance access, then quit so its safe to test. Still, you are using it at your own risk.

http://www.flemcodesign.com/files/GEMSFIXER.zip

Opening screen



After clicking Alarm pair, then go, here is what you should see if everything was successful.


If you make money off this you are a fucking asshole. No recouping costs of equipment, I'm not recouping anything so if you want to help your friends/club you are doing so for free.
Reply With Quote
  #213  
Old 04-13-2018, 09:30 AM
WaltNYC's Avatar
WaltNYC WaltNYC is online now
Member
 
Join Date: Mar 2010
Location: NYC
Posts: 378
Member Trucks
robert, thank you very much for providing this code. Fortunately I have not needed to use it, but it sure is nice to know that I have options when/if I do.
__________________
1997 Discovery I SE - 150k miles

RAVE in pdf:
https://drive.google.com/open?id=0By...FdyX1VQMS1iN00
Discovery I exploded parts diagrams....
http://www.allbrit.de/NAV.cfm?SPRACHE=EN&PAGE=491338
Reply With Quote
  #214  
Old 04-13-2018, 11:31 AM
Injuhneer's Avatar
Injuhneer Injuhneer is offline
Member
 
Join Date: Nov 2011
Location: Southeastern Arizona (near Tombstone)
Posts: 399
Member Trucks
"If you make money off this you are a f^@%#* as&^$!. No recouping costs of equipment, I'm not recouping anything so if you want to help your friends/club you are doing so for free."

I was thinking thief, slime, scum or butt-munch was a simple enough description. LOL
__________________
./----\˛
|―-|―\--,
́́́́ '-O----O˚
__Лˉ\_Дˉ\__
-< Mike O. >-
'97 Disco I SE V8i - No major mods
1971 Honda ST90: 160cc stroker with CT90 Hi/Lo



Reply With Quote
  #215  
Old 04-13-2018, 07:48 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Quote:
Originally Posted by Injuhneer View Post
"If you make money off this you are a f^@%#* as&^$!. No recouping costs of equipment, I'm not recouping anything so if you want to help your friends/club you are doing so for free."

I was thinking thief, slime, scum or butt-munch was a simple enough description. LOL
I had several people claiming work I put on thingiverse as their own so I need to be as explicit as possible
Reply With Quote
  #216  
Old 04-16-2018, 05:50 PM
Injuhneer's Avatar
Injuhneer Injuhneer is offline
Member
 
Join Date: Nov 2011
Location: Southeastern Arizona (near Tombstone)
Posts: 399
Member Trucks
Quote:
Originally Posted by robertf View Post
I had several people claiming work I put on thingiverse as their own so I need to be as explicit as possible
I get it. I made some replacement panels for the D1 console switches. I was wondering if I put them on thingiverse if they would be "re-purposed".
__________________
./----\˛
|―-|―\--,
́́́́ '-O----O˚
__Лˉ\_Дˉ\__
-< Mike O. >-
'97 Disco I SE V8i - No major mods
1971 Honda ST90: 160cc stroker with CT90 Hi/Lo



Reply With Quote
  #217  
Old 04-22-2018, 10:47 PM
JUKE179r's Avatar
JUKE179r JUKE179r is online now
Member
 
Join Date: Sep 2016
Location: Suffolk, England
Posts: 155
Member Trucks
Cheers robertf!!!!
__________________
Pictures of Disco Myrtle... https://discoweb.org/showthread.php?t=94365

- 2001 Java Black Discovery 2 SE (LHD) "MYRTLE", 107K miles, 4.0L V8, SAI, Safari Gard bumpers, Warn XD9000i winch, KO2 265/75R16 on steel rims, 3" TF lift, LEDs, UltraGauge Blue, Foxwell NT510, Nanocom Evo II
Reply With Quote
  #218  
Old 04-25-2018, 02:18 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Was messing with the program tonight and just realized that version I uploaded sends trash instead of the actual reset but appears to work anyways. Alarm pair does actually work. I'll put up a fixed version later.

The good news is that I got it working with an elm327 compatible cheap chinese reader . this one specifically , so it's no longer tied in to custom hardware.

And heads up, if you leave a cheap bluetooth dongle that doesn't have a physical pair button plugged in to your GEMS truck and your phone isn't actively paired to it you are vulnerable to an adaptive values attack. takes about 10 seconds plus bluetooth pair time
Reply With Quote
  #219  
Old 04-26-2018, 01:35 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
http://www.flemcodesign.com/files/GEMSFIXER2.1.zip

fixed. works with bluetooth, so if you can pair any elm327 compatible bluetooth, usb, or serial device to a windows XP machine or newer it should work
Reply With Quote
  #220  
Old 05-03-2018, 03:46 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Almost there

Reply With Quote
  #221  
Old 05-05-2018, 12:53 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Android reader available here.
https://play.google.com/store/apps/d...ms.gemsutility








No writer yet

Last edited by robertf; 05-05-2018 at 02:14 PM.
Reply With Quote
  #222  
Old 05-12-2018, 12:36 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Updated, it now does all the resets.
https://play.google.com/store/apps/d...ms.gemsutility
Reply With Quote
  #223  
Old 05-14-2018, 04:28 PM
DirtyRedDisco DirtyRedDisco is offline
Junior Member
 
Join Date: Mar 2018
Location: Utah
Posts: 1
You Sir are an absolute hero of the GEMS Rovers. Thank you for all the work you put into this. It works like a charm.
Reply With Quote
  #224  
Old 05-17-2018, 11:37 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,863
Member Trucks
Good to hear. Was that the android or windows version?

Working on ios version since thats what ive got, but theres a steep learning curve in their goofy language
Reply With Quote
  #225  
Old 05-18-2018, 04:51 PM
hrhoward's Avatar
hrhoward hrhoward is offline
Still Junior
 
Join Date: Jan 2016
Location: Huntsville, AL
Posts: 22
Member Trucks
Crap,
I'm getting this:

Attached Images
File Type: jpg Capture.JPG (25.0 KB, 19 views)
__________________
1997 Discovery
4.0 ('98), SD, Automatic
It was free.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GEMS adaptive values reset? Tugela Discovery - Technical Discussions 4 01-01-2015 03:59 PM
oil change NVRover LR4/LR3 - Technical Discussions 17 03-23-2010 12:03 AM
SLC Amigo reset or testbook/rovacom? rob mellor Discovery - Technical Discussions 3 07-11-2009 07:44 PM
how to reset adaptive values a2tripp Discovery - Technical Discussions 34 10-20-2008 09:54 PM
Does SES light reset itself? usna87 Discovery - Technical Discussions 4 07-17-2006 07:00 AM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
cdmbrennan
ME Island
dave_lucas (47)
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 04:00 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.