DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 09-11-2018, 09:05 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
Here is the question: I am finishing up converting a 1998 D1 from V8 auto to 300TDI with 5 speed.

I am down to the little odds and ends in finishing it up. I am using a factory 300TDI engine harness which came with the glow plug timer / relay and harness. It is working well but I cannot find a light / wire from the instrument cluster to sub as the glow plug indicator.

On the 300TDI wiring diagram it shows a purple orange wire going the glow plug indicator light but I cant find that color wire in my V8 harness. I have located the correct black yellow wire in the 300TDI engine harness.

I remember someone mentioning using one of the indicator lights on the dash for this purpose but forgot what they said and who it was.

Anyone know?

Thanks in advance.
Reply With Quote
  #2  
Old 09-12-2018, 12:05 PM
German Gruner's Avatar
German Gruner German Gruner is offline
Member
 
Join Date: Nov 2015
Location: Boulogne, Bs. As., Argentina
Posts: 221
Member Trucks
Dash lights came here in the south, the same both in V8 and TDI engine versions.
right up is this yellow indicator light

Source lines are F14 (+12V) with a light green cable and mass from glow plugs relay comes into dash via a violet/orange cable position 6 of C209. You can find it near fusebox below drivewheel.
This information is based in a non- NAS 1998 D1

Regards
__________________
_________________________
1998 D1300 TDI & 2003 DII Td5 hse
Reply With Quote
  #3  
Old 09-12-2018, 01:49 PM
Leadvagas Leadvagas is offline
Member
 
Join Date: Jun 2010
Location: Leadville CO
Posts: 221
Member Trucks
After having done the 300TDI on several discos, what I have found is that the indicator is present on the cluster but the wire positions on the plug, C 209 are different from NAS to Europe. On my 95 I got a European cluster, the cluster light stays on with key on but the glow plug indicator works. My NAS cluster wouldn’t give me the glow plug indicator no matter how I arranged C209. On a couple I helped with we used the Check Engine Light.
Reply With Quote
  #4  
Old 09-12-2018, 02:09 PM
German Gruner's Avatar
German Gruner German Gruner is offline
Member
 
Join Date: Nov 2015
Location: Boulogne, Bs. As., Argentina
Posts: 221
Member Trucks
Check engine light is not used by "european" 300TDI?s and position is the same from V8?s.
In year 2003 I used this light to get an overheating/low coolant level alarm, very useful for diesel engine.
https://translate.google.com.ar/tran...-text=&act=url
(Very old link,duplicated below in order to replace images)

Regards
__________________
_________________________
1998 D1300 TDI & 2003 DII Td5 hse
Reply With Quote
  #5  
Old 09-12-2018, 03:11 PM
Leadvagas Leadvagas is offline
Member
 
Join Date: Jun 2010
Location: Leadville CO
Posts: 221
Member Trucks
I wired the glow plug relay to the CEL on NAS instrument clusters because I couldn’t get the glow plug indicator to work on the NAS cluster. I don’t think there is a pathway from the plug to the indicator on NAS instrument cluster. I wanted the glow plug indicator on my Disco, so I had them pull the cluster from the 300TDI Disco when they pulled the TDI, my motor and instrument cluster came from England.
Reply With Quote
  #6  
Old 09-12-2018, 03:12 PM
Leadvagas Leadvagas is offline
Member
 
Join Date: Jun 2010
Location: Leadville CO
Posts: 221
Member Trucks
Thanks for the link, I will look at it tonight
Reply With Quote
  #7  
Old 09-12-2018, 08:55 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
So, here is what I did. I found the CEL indicator wire which is Red with a Gray stripe. It is a perfect candidate as the orange CEL has no purpose without the V8 ECU. If you ground it the indicator light comes on. I connected it to the black with yellow stripe wire coming from the the glow plug relay. I then connected the black trigger wire powered when the ignition is turned on, the same source as the injection pump. (I do not understand why LR chose black for a power lead.)

I did not get the results I wanted. The glow plug relay activates and sends power to the glow plugs but doesnt cause the CEL light to come on.

If I am correct when the relay sends power to the glow plugs it also causes the wire to the dash indicator light to go to ground, resulting in the light going on. Can anyone confirm that? Also, the relay either stays on until I disconnect power or clicks on for just 2 or 3 seconds and goes off. Regardless of whether it stays on (too long) or clicks off quickly the CEL light does not illuminate.

It seems to me the relay is not grounding the dash light and when it energizes the glow plugs it either gets stuck on or cycles too short.

Do you think I have a bad relay or something else is going on?
Reply With Quote
  #8  
Old 09-12-2018, 09:39 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
German, unrelated to this topic, but could you take a photo the mounts to the gearbox / transfer case. I purchased my 300TDI kit from Land Rover import and think something has been customized in what they sent to me. The new mounts I purchased are in no way close to usable with the steel mount bases. It currently has very worn out round “hockey puck” like mounts. One of which really doesnt fit. The new mounts I ordered are quite different.
Reply With Quote
  #9  
Old 09-13-2018, 09:17 AM
German Gruner's Avatar
German Gruner German Gruner is offline
Member
 
Join Date: Nov 2015
Location: Boulogne, Bs. As., Argentina
Posts: 221
Member Trucks
Quote:
Can anyone confirm that?
Yes it?s correct. Glow Plug relay has additionally a line coming from starter relay, in order to going off when starting, when (+12v) is received.

Yesterday night I crouched on the floor, to took these cell phone-pictures. Tell me if there is some detail you need but do not see it


imagenes para pagina web





apologies for the dirt, haha!

Regards
__________________
_________________________
1998 D1300 TDI & 2003 DII Td5 hse
Reply With Quote
  #10  
Old 09-13-2018, 01:13 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
German, many thanks for the advise and photos!
Reply With Quote
  #11  
Old 09-13-2018, 01:30 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
I need one of those crossmembers.
Reply With Quote
  #12  
Old 09-13-2018, 01:33 PM
Tugela's Avatar
Tugela Tugela is offline
Member
 
Join Date: May 2007
Location: Seattle
Posts: 3,829
Quote:
Originally Posted by German Gruner View Post
Tell me if there is some detail you need but do not see it
There are a couple details missing that I do not see: no leaks from your transfer case or transmission or oil pan. Either you deserve a gold star for excellent maintenance or you need to run out there and check your fluid levels!
__________________
"Americans can always be counted on to do the right thing,
once they have exhausted the alternatives." Winston Churchill


1998 Discovery LSE
1993 Range Rover County Sport
Global Exploration and Recovery, LLC
Reply With Quote
  #13  
Old 09-13-2018, 02:50 PM
German Gruner's Avatar
German Gruner German Gruner is offline
Member
 
Join Date: Nov 2015
Location: Boulogne, Bs. As., Argentina
Posts: 221
Member Trucks
Quote:
There are a couple details missing that I do not see: no leaks from your transfer case or transmission or oil pan. Either you deserve a gold star for excellent maintenance or you need to run out there and check your fluid levels!
19 years in the family, 285000km travelled and in order not to "send" it to repair to a mechanic, I did bought a D2 that allowed to stop the march of it. Last year I myself overhauled transmission and the love with which task was done and less than 10,000km travelled allowed it to still look as new.

Regards
__________________
_________________________
1998 D1300 TDI & 2003 DII Td5 hse
Reply With Quote
  #14  
Old 09-15-2018, 11:25 PM
terryjm1 terryjm1 is offline
Almost There...
 
Join Date: Jan 2011
Posts: 42
Got the glow plug system working right today with the CEL light on the dash. Thanks for the help!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
300tdi Conversion for Auto V8 D2 globallandrovers Parts For Sale 0 12-17-2015 09:52 AM
Silly Question About The Low Gear Dash Light MB3 Discovery - Technical Discussions 9 11-16-2010 11:17 PM
CDL Dash light question(won't go away!) bluejayranger Discovery - Technical Discussions 3 04-04-2009 07:25 AM
plug in tuning box for a 300tdi albert_swafega Discovery - Technical Discussions 1 08-22-2006 01:19 PM
F-this Gas crap. How much to do a 300TDi conversion? Craigness Discovery - Technical Discussions 74 09-29-2005 09:17 AM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
wallyman424 (33)
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 06:55 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.