DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
  #226  
Old 06-12-2018, 03:41 PM
hrhoward's Avatar
hrhoward hrhoward is offline
Still Junior
 
Join Date: Jan 2016
Location: Huntsville, AL
Posts: 22
Member Trucks
Been using the Android app. On my Samsung GS8 the app will crash during read sequence. Dusted off my Samsung GS3 and it works fine. Using an OBDLinx LX Bluetooth.
__________________
1997 Discovery
4.0 ('98), SD, Automatic
It was free.
Reply With Quote
  #227  
Old 06-13-2018, 02:57 PM
rover rob rover rob is offline
Member
 
Join Date: Mar 2016
Location: upstate NY
Posts: 71
Member Trucks
Quote:
Originally Posted by robertf View Post
Updated, it now does all the resets.
https://play.google.com/store/apps/d...ms.gemsutility
thank you so much for this. just downloaded the app. cant wait to try it.
Reply With Quote
  #228  
Old 06-21-2018, 07:16 PM
psdforever psdforever is offline
Junior Member
 
Join Date: Jan 2015
Location: Ohio
Posts: 18
I can't thank this group enough. I hosed my adaptive values by having a broken MAF sensor that broke and fell apart, and driving for a few days with the air filter temp sensor unplugged (because I forgot to plug it back in) and I got the dreaded high idle. Ready to burn this thing to the ground.

I stumble on this thread, download the android app, wait 2 days for the ODB link to come from Amozon Prime, and all I can say is THANK YOU!!

It took me longer to find the connect button on the ODB link than it did to reset the adaptive values and by magic, idle fixed!!!!!

I can't believe I've paid the dealer $100 a couple of times to "press their button"

I can tell you I would gladly pay for this app and update it if a newer version is developed in the future.

Thank you!!!

On edit, worked great with a samsung galaxy S4. 1999 Land Rover Disco 1, SD
Reply With Quote
  #229  
Old 06-21-2018, 07:26 PM
nuke_123992 nuke_123992 is offline
Junior Member
 
Join Date: Jun 2017
Location: Illinois
Posts: 10
Wow awesome Robert!

I've not seen notifications on this post till now, some great improvements since the initial! I appreciate all the work
Reply With Quote
  #230  
Old 06-21-2018, 08:33 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,876
Member Trucks
Quote:
Originally Posted by psdforever View Post
I can't thank this group enough. I hosed my adaptive values by having a broken MAF sensor that broke and fell apart, and driving for a few days with the air filter temp sensor unplugged (because I forgot to plug it back in) and I got the dreaded high idle. Ready to burn this thing to the ground.

I stumble on this thread, download the android app, wait 2 days for the ODB link to come from Amozon Prime, and all I can say is THANK YOU!!

It took me longer to find the connect button on the ODB link than it did to reset the adaptive values and by magic, idle fixed!!!!!

I can't believe I've paid the dealer $100 a couple of times to "press their button"

I can tell you I would gladly pay for this app and update it if a newer version is developed in the future.

Thank you!!!

On edit, worked great with a samsung galaxy S4. 1999 Land Rover Disco 1, SD

cool. Something is up with the s8 that I'll eventually look into (aka, I'm lazy and added no error handling to some type conversions, and I believe it actually crashes when the exit button is closed instead of closing correctly, same result but it generates an error report)

eventually I'll get it where you can write values for VIN, displacement, transmission, but I've noticed a couple of discrepancies in this that I have to investigate. I don't believe its possible to set both the manual and 4.6 flags, but since I've never seen what the actual rover dealer tool does its possible that all the aftermarket comm tools have the same glitch and are setting the wrong bits. That number above the reader type (01 in the picture) is the value for the trans and engine option. I don't remember what translates to what without looking at my notes, but I want to makes sure I'm not setting it to something that will cause problems before releasing that.

May have to charge for the next iteration. I attempted the google ad pay thing and I havent hit double digit cents yet.
Reply With Quote
  #231  
Old 06-21-2018, 11:16 PM
psdforever psdforever is offline
Junior Member
 
Join Date: Jan 2015
Location: Ohio
Posts: 18
Robert, please keep us updated. I'm totally amazed and guess I'll keep the disco a bit longer
Reply With Quote
  #232  
Old 06-23-2018, 03:53 PM
ptschram's Avatar
ptschram ptschram is offline
Encyclopaedia Brown
 
Join Date: Sep 2004
Location: In the shop doing the Lord's work one broken Rover at a time
Posts: 21,831
Robert

Which interfaces will this work with?

Will it work with the J2534 vehicle communications interface?
__________________
Dominic Perodeau and John Monaghan are thieves.

I'm still in the parts and engine building business-my service activities are being reduced, not my interest in serving the Rover community

I am easily contacted via text message to 260-804-0458 or pt@ptschram.com. PMs are least reliable
Reply With Quote
  #233  
Old 06-23-2018, 04:56 PM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,876
Member Trucks
Quote:
Originally Posted by ptschram View Post
Robert

Which interfaces will this work with?

Will it work with the J2534 vehicle communications interface?
Elm327 compatible
Reply With Quote
  #234  
Old 06-24-2018, 08:54 AM
nuke_123992 nuke_123992 is offline
Junior Member
 
Join Date: Jun 2017
Location: Illinois
Posts: 10
Quote:
Originally Posted by robertf View Post
May have to charge for the next iteration. I attempted the google ad pay thing and I havent hit double digit cents yet.
Fair enough, considering how infrequently this is probably used currently that makes sense.

As the word gets out, it may bump up a little bit.
Reply With Quote
  #235  
Old 07-03-2018, 09:42 AM
yoseffby yoseffby is offline
Junior Member
 
Join Date: Nov 2017
Location: Marfa
Posts: 11
Thank you for this great tool Robert! I was wondering if the immobilizer function is what I would need if I'm interested in replacing my ecu without dealer support? If not what function does it serve?
Reply With Quote
  #236  
Old 07-03-2018, 01:43 PM
hrhoward's Avatar
hrhoward hrhoward is offline
Still Junior
 
Join Date: Jan 2016
Location: Huntsville, AL
Posts: 22
Member Trucks
Quote:
Originally Posted by robertf View Post
May have to charge for the next iteration. I attempted the google ad pay thing and I havent hit double digit cents yet.
I'd throw a few bones your way. Do you have a PayPal account or something similar?
__________________
1997 Discovery
4.0 ('98), SD, Automatic
It was free.
Reply With Quote
  #237  
Old 07-03-2018, 11:40 PM
thesoaringpotato thesoaringpotato is offline
Junior Member
 
Join Date: Jun 2018
Location: Seattle
Posts: 6
Member Trucks
Hi RobertF, first of all, big thanks for putting this out. This is an incredibly valuable tool.


Unfortunately I'm getting the same error as hrhoward, libgcc_s_dw2-1.dll was not found (and some other files), and do not have a access to an Android. Is there a dependency I'm missing that I need to download somewhere?


Thanks in advance!






Quote:
Originally Posted by hrhoward View Post
Crap,
I'm getting this:

Reply With Quote
  #238  
Old 07-04-2018, 12:23 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,876
Member Trucks
It might be part of mingw. Ill dig around tomorrow
Reply With Quote
  #239  
Old 07-04-2018, 01:29 AM
thesoaringpotato thesoaringpotato is offline
Junior Member
 
Join Date: Jun 2018
Location: Seattle
Posts: 6
Member Trucks
Hey, I got it working by locating these files:



libgcc_s_dw2-1.dll
libstdc++-6.dll
libwinpthread.dll


They are zipped up here: https://file.io/o5Y1fV


I got them from downloading QT for Windows, version 5.80


Unfortunately I was unsuccessful in communicating with the ECU


I was able to communicate using a different program, so the connection is good at least.


I'm using an ELM327 bluetooth dongle:


https://www.amazon.com/gp/product/B0...?ie=UTF8&psc=1


Thanks Robert!



Quote:
Originally Posted by robertf View Post
It might be part of mingw. Ill dig around tomorrow
Attached Images
File Type: png Error.PNG (21.8 KB, 3 views)
Reply With Quote
  #240  
Old 07-04-2018, 11:51 AM
robertf robertf is online now
Member
 
Join Date: Jan 2006
Location: Dallas
Posts: 3,876
Member Trucks
I had moved on to the android version before I realized I could make it work with a generic elm chipset, so right now the windows version won't work with your setup, only the scantool cable or BT module. I'll try to get around to updating it soon.

if you care about the why it doesnt work here is the boring stuff... the elm stuff doesn't fully support all of the OBD2 protocol. theres a couple different message formats that are possible, it only supports the ones that have headers. All of the rover factory scantools use the message format without headers. scantool chipset allows turning off the headers, elm doesnt, and I never bothered to try it with headers since I was just trying to emulate a rover scantool. Turns out GEMS accepts both formats, which makes it a pretty good ECM in my opinion. Interestingly the TD5 ECU does not support the header format which if you look at the foreign forums you will see all kinds of arguments about is TD5 obd2 compliant or not. The fault is with the elm readers not being compliant, not the TD5 ECU.
Reply With Quote
  #241  
Old 07-04-2018, 11:56 AM
thesoaringpotato thesoaringpotato is offline
Junior Member
 
Join Date: Jun 2018
Location: Seattle
Posts: 6
Member Trucks
Ah, gotcha. That makes total sense, and I really appreciate the explanation. I went ahead and bought the ScanTool since the GEMSFixer already works with that tool. Should be here in a few days. Thanks again for your help with this!


Cheers!


Alfredo
Reply With Quote
  #242  
Old 07-08-2018, 02:26 PM
thesoaringpotato thesoaringpotato is offline
Junior Member
 
Join Date: Jun 2018
Location: Seattle
Posts: 6
Member Trucks
Cable came in, and the tool worked like a charm, thanks Robert!


Do you take contributions? PayPal or Venmo? Let me know the deets through PM. Cheers!


Alfredo
Reply With Quote
  #243  
Old 10-09-2018, 01:31 PM
psykokid's Avatar
psykokid psykokid is offline
Member
 
Join Date: May 2006
Location: Pasadena, CA
Posts: 79
Robert,

Thanks for taking the time to figure this out. It's a great resource to the community.

Back when you first released it I wasn't able to get the windows version to work on my PC, but it worked fine with the OBDLink LX on my wife's macbook. That was good as I had done a bunch of work and needed to reset the adaptives and get the truck smogged. Worked like a charm.

Earlier in the year I saw that you had written and android port and tried it out when you first put it on the play store. The program would load but would crash after connecting. Tried a few times and then sort of forgot about it. Last night I finally got my truck running after the head gasket let go a few months ago. Figured it could do with a re-set and tried running the app again. The first couple of times I would get the crash when trying to connect so I went ahead and tried again. Finally connected and was able to read the data from the ECU. Now when I select adaptive values reset and then apply changes the app quits. Tried again and after the same cycle of no go, no go, and success it read the info, the values were different from the previous ones so I assume it reset. For good measure I tried again and selected adaptive values reset then apply changes the app still crashes.

I reported the error so hopefully you got the error log. Not sure if it's of any use but I'm using the OBDLink LX BT adapter with a Google Pixel XL running Android Pie with the latest security release/update.
__________________
1997 Disco SE7
2000 VW Passat 4-Motion Wagon
1976 VW Scirocco
Reply With Quote
  #244  
Old 10-11-2018, 09:28 AM
nuke_123992 nuke_123992 is offline
Junior Member
 
Join Date: Jun 2017
Location: Illinois
Posts: 10
I noticed the same crash, and of course today my truck started doing the 2krpm idle again and needs a reset

Edit:

I tried all the downloads here, GEMS11 works, the others gave me missing DLL errors, or "access denied" when trying to connect to the comm port.

The android worked as well, but only on an older version of android OS, so not sure what changed there.

Last edited by nuke_123992; 10-13-2018 at 09:29 PM.
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
GEMS adaptive values reset? Tugela Discovery - Technical Discussions 4 01-01-2015 03:59 PM
oil change NVRover LR4/LR3 - Technical Discussions 17 03-23-2010 12:03 AM
SLC Amigo reset or testbook/rovacom? rob mellor Discovery - Technical Discussions 3 07-11-2009 07:44 PM
how to reset adaptive values a2tripp Discovery - Technical Discussions 34 10-20-2008 09:54 PM
Does SES light reset itself? usna87 Discovery - Technical Discussions 4 07-17-2006 07:00 AM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
None
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 02:06 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.