DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 11-13-2018, 10:18 AM
_ExpeditionMan _ExpeditionMan is offline
Junior Member
 
Join Date: Dec 2017
Location: Fort Worth, TX
Posts: 15
Member Trucks
All,

1996 D1 5spd - I have two issues which, according to my read of the electrical diagram for NAS Manual trucks, are most likely related. My cruise control is not working and neither is my speedometer. It is important to note that my odometer is functioning correctly. While troubleshooting the cruise control using this guide I was able to confirm that vehicle speed sensor does read near zero at stop and bounce upwards to 8-12 volts when driving. Thus I suspect my VSS is functioning correctly. The only test from the guide that failed was the secondary voltage test and I believe the NAS Manual trucks use a slightly different system than the auto trucks (not a lockout relay) per the RAVE.

So in summary:
-Odometer functions correctly
-Instrument panel fuse is good
-UltraGauge reads speed with no issues
-No driveability issues (idle, stuttering, exc.)
-Tests according to guide above pass, except secondary voltage test (which may not be applicable for NAS Manual)

Am I looking at a hardware failure of the speedometer itself? Am I misreading the RAVE electrical diagram and I have a bad lockout relay preventing my CC from actuating? I thought the speedometer was basically just a meter looking at the voltage reading supplied from the VSS, am I incorrect here?

Thanks,

Jonathon
__________________
1996 Discovery 1 SE7 5spd
-A resurrection in progress-
Reply With Quote
  #2  
Old 11-13-2018, 10:39 AM
Doug C's Avatar
Doug C Doug C is offline
Member
 
Join Date: Jul 2006
Location: Central, Virginia
Posts: 492
The VDO cruise control units in d1's are known to be a high failure item. The fix is to splice in the connector and control unit from a d2.
__________________
Doug Crowther

http://www.dividingcreekimports.com
Reply With Quote
  #3  
Old 11-13-2018, 11:59 AM
_ExpeditionMan _ExpeditionMan is offline
Junior Member
 
Join Date: Dec 2017
Location: Fort Worth, TX
Posts: 15
Member Trucks
Quote:
Originally Posted by Doug C View Post
The VDO cruise control units in d1's are known to be a high failure item. The fix is to splice in the connector and control unit from a d2.
VDO? Can you elaborate? Is it one of the components I listed in the test write-up that I linked?
__________________
1996 Discovery 1 SE7 5spd
-A resurrection in progress-
Reply With Quote
  #4  
Old 11-18-2018, 09:19 PM
thesoaringpotato thesoaringpotato is offline
Junior Member
 
Join Date: Jun 2018
Location: Seattle
Posts: 6
Member Trucks
Not sure what VDO means, but he's referring to the cruise control electronic control module, ECU (lives behind the glove box). I went through the same writeup fixing my cruise control, and it turned out my ECU went bad.


Check out this link: https://landroverforums.com/forum/di...rol-ecu-57040/



Find yourself a cruise control ECU from a D2, preferably one that came with the 4.0, not 4.6 (the ECUs were tuned differently). Wire up the pigtail from the D2 to the D1.
Reply With Quote
  #5  
Old 11-20-2018, 11:47 AM
Rocky Rocky is offline
Member
 
Join Date: Apr 2004
Location: Red Sox Nation
Posts: 2,107
VDO is a manufacturer of instruments. Guess they also made CCs.
__________________
Lots of parts needing to be bolted on....
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
5spd in a DII? BigLouAamich Discovery - Technical Discussions 6 11-04-2018 09:48 PM
97 D1 SD 5spd Shiftonthefly1 Vehicles For Sale 8 03-02-2017 06:07 PM
'95 5spd PMA1420 Vehicles For Sale 29 03-12-2011 12:30 AM
5spd D2 ?????? FIVESPDDISCO Discovery - Technical Discussions 119 08-17-2010 12:04 PM
5spd clutch question FIVESPDDISCO Discovery - Technical Discussions 1 03-10-2007 01:16 AM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
s2landie (45)
MyR1isFun (44)
Carl_kps (43)
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 03:06 PM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.