DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Discovery - Technical Discussions

Reply
 
Thread Tools Display Modes
  #1  
Old 07-21-2004, 06:55 PM
RayDunn RayDunn is offline
Member
 
Join Date: Jul 2004
Location: Nashville, TN
Posts: 83
My engine idles really low and turned off this morning. This is a problem that happens from time to time, but without any patterns. The engine has about 130,000 miles on it, but has been kept up and normally runs fine. The last time I had the spark plugs changed was at 95,000 miles (during the 30,000 mile service). If anyone has any ideas let me know. Thanks!
Reply With Quote
  #2  
Old 07-21-2004, 07:12 PM
Hoot Hoot is offline
Member
 
Join Date: Apr 2004
Location: Bloomfield twp, MI
Posts: 227
It could be a lot of things but just going form what i have read on here a few of the common things that can cause that are a dirty stepper motor, and a clogged fuel filter.
__________________
96 Disco
Reply With Quote
  #3  
Old 07-22-2004, 01:54 PM
polofella26
Guest
 
Posts: n/a
Mine does the same thing when I start it. I replaced the fuel filter and the issue is still there. Anyone know for sure?
Reply With Quote
  #4  
Old 07-22-2004, 02:25 PM
rpm2429 rpm2429 is offline
Member
 
Join Date: Jun 2004
Location: denver, co
Posts: 54
I ditto the stepper motor, whenever I have cleaned mine it does the same thing for a day until it dries out and then everything is back to normal.
Reply With Quote
  #5  
Old 07-28-2004, 02:29 PM
rovrjnky's Avatar
rovrjnky rovrjnky is offline
Almost There...
 
Join Date: Apr 2004
Location: Broomfield, Colorado
Posts: 47
where is the stepper motor located?
__________________
God forgives, rocks don't !!!
Reply With Quote
  #6  
Old 07-28-2004, 02:44 PM
Hoot Hoot is offline
Member
 
Join Date: Apr 2004
Location: Bloomfield twp, MI
Posts: 227
there was a post on this not to long ago where someone put up dogotal photos showing the locales. where it is depends on what year your disco is. on the 95 the stepper is on the back rear of the plenum on the passenger side. on the newer 4.0 engines it is on the front right side of the plennum. if you have a D2 then i dont know where it is.
__________________
96 Disco
Reply With Quote
  #7  
Old 07-28-2004, 04:53 PM
FIVESPDDISCO's Avatar
FIVESPDDISCO FIVESPDDISCO is offline
Lucky8 Off Road
 
Join Date: Apr 2004
Location: Clarence center
Posts: 6,773
dont forget about the fule pump
__________________
For expedition tested Rover gear Check out WWW.Lucky8LLc.com 716-898-8153
Reply With Quote
  #8  
Old 07-28-2004, 05:14 PM
polofella26
Guest
 
Posts: n/a
What about the fuel pump?
Reply With Quote
  #9  
Old 07-28-2004, 05:26 PM
FIVESPDDISCO's Avatar
FIVESPDDISCO FIVESPDDISCO is offline
Lucky8 Off Road
 
Join Date: Apr 2004
Location: Clarence center
Posts: 6,773
fule pump

if the pump is old and not giving the presure it need to run the truck is one thing. if the electrical conections are going bad the pump will run poorly. or the pump could be bad. i would check it out before i order one they are around $300
__________________
For expedition tested Rover gear Check out WWW.Lucky8LLc.com 716-898-8153
Reply With Quote
  #10  
Old 07-28-2004, 08:34 PM
Discobro
Guest
 
Posts: n/a
It could be either of those two. Most likely the stepper motor (technically referred to as Idle Air Control (IAC) Valve). Here is a photo of where it is located on a 96 D1 4.0.
Attached Images
File Type: jpg IAC.jpg (55.1 KB, 138 views)
Reply With Quote
  #11  
Old 07-29-2004, 04:40 PM
jmonsrvr's Avatar
jmonsrvr jmonsrvr is offline
Member
 
Join Date: Apr 2004
Location: montara, ca & newport beach, ca
Posts: 819
if its a d1 you can pick up the stepper at napa auto parts for around 35 dollars. they have two types that work..i cant remember the part # though
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine management fuse blowing Max Discovery - Technical Discussions 2 10-24-2008 10:35 PM
Code 45 - Truck idles rough when stopped and dies intermittenly don_r6 Discovery - Technical Discussions 6 12-26-2007 05:57 PM
Idle is going way too low during stopping mikemeyer0 Discovery - Technical Discussions 3 10-26-2005 08:40 PM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
None
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 11:57 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.