DiscoWeb Message Boards
 

Go Back   DiscoWeb Message Boards > DiscoWeb Technical Boards > Range Rover - Technical Discussions

Reply
 
Thread Tools Display Modes
Old 10-16-2017, 11:35 AM   #1
JohnnoK
Almost There...
 
Join Date: Mar 2017
Location: Cape Town, South Africa
Posts: 34
Member Trucks
Default P38 EAS weird stuff...

OK, I officially need serious help now. I am so far out of my depth it's not funny....

I made up the cable and hooked up the PC to run the freeware and it revealed a litany of errors.
F8 = 69
F9 = 227
FA = 213
FB = 0
FC = 255
FL signal incorrect
FR signal incorrect
RR signal incorrect
Engine speed fault
Vehicle speed fault
Air supply leak
Target heights incorrect
Vehicle has moved
Cannot lower FR
Cannot lower FL
FA:16_Hidden
FA:64_hidden
FL valve stuck closed
FR ditto
RL ditto
RR ditto
Inlet valve stuck closed
Exhaust valve stuck closed
FC:64_hidden
FC:128_hidden
Each time I run the program, it has different errors.

When I read the heights, I get
HIGH Profile: FL = 0, FR = 6, RL = 0, RR = 14
STANDARD Profile: FL = 0, FR = 0, RL = 0, RR = 247
LOW profile: 0, 0, 0, 14
ACCESS Profile: 0, 0, 0, 247
and, if I do them again, they are different again....

When I "get sensor heights"
LF = 128, RF = 40, LR = 128, RR = 40
and, if I do them again, they are different again....

As for the " Cannot lower FL and FR in the errors, I set sail to town this morning to buy the bits for the cable and having manually inflated the old girl to approximately level, I plugged the valve body and compressor in, turned the key to start it and, as soon as it started, it dropped the front onto the bump stops. I limped to a service station, inflated the front again and as soon as I started it, back on the stops.....
I unplugged it all, inflated it again and ran my errands, came home and got the errors above when I fired the PC up.....

So, where do I even start debugging this shambles?
__________________
Cheers,
John

'99 Disco II Td5
'99 P38 HSE GEMS
'75 Rover P6B 3500
'03 Aprilia Tuono RST1000
'77 Moto Guzzi LeMans 850
JohnnoK is offline   Reply With Quote
Old 10-16-2017, 12:25 PM   #2
CORover
Member
 
CORover's Avatar
 
Join Date: Jun 2007
Location: Colorado, USA
Posts: 210
Default Re: P38 EAS weird stuff...

I see you cross posted this, you will probably get better info at RR.net. Just be patient.
__________________
96 Disco - Heavily Modified but not done yet
00 Range Rover - Mostly Stock
00 Range Rover - Mostly Dead
CORover is offline   Reply With Quote
Old 10-17-2017, 09:44 AM   #3
JohnnoK
Almost There...
 
Join Date: Mar 2017
Location: Cape Town, South Africa
Posts: 34
Member Trucks
Default Re: P38 EAS weird stuff...

Quote:
Originally Posted by CORover View Post
I see you cross posted this, you will probably get better info at RR.net. Just be patient.
Yep, a bit of a Hail Mary...
__________________
Cheers,
John

'99 Disco II Td5
'99 P38 HSE GEMS
'75 Rover P6B 3500
'03 Aprilia Tuono RST1000
'77 Moto Guzzi LeMans 850
JohnnoK is offline   Reply With Quote
Old 10-17-2017, 11:28 AM   #4
CORover
Member
 
CORover's Avatar
 
Join Date: Jun 2007
Location: Colorado, USA
Posts: 210
Default Re: P38 EAS weird stuff...

I have never run that software before. I did use some free stuff this guy used to offer and may still be around on some sites. He has lots of P38 info too. What I saw with his software was that unreliable results were usually related to communication issues either with the cable or the computer comms settings. Maybe you can find something here.

http://www.rswsolutions.com/index.php/range-rover-p38a

Have you tried pulling the EAS delay timer from under the driver seat, LHD? It puts the system in manual mode but also kills computer connectivity so use it only when you need to.
__________________
96 Disco - Heavily Modified but not done yet
00 Range Rover - Mostly Stock
00 Range Rover - Mostly Dead
CORover is offline   Reply With Quote
Old 10-17-2017, 10:47 PM   #5
discostew
Member
 
Join Date: Sep 2010
Location: Norther Illinois
Posts: 4,034
Default Re: P38 EAS weird stuff...

I really have no idea what kind of software or what you have going on but I would be looking at why that rear corner sensor value is never at 0 with all the other boys.I cant remember if LP's had different sensor each corner. You need to know for sure what the corner height sensor voltage at each corner really is. Find a schematic and some t pins and measure the circuits with a meter maybe.

I would also make sure the sensor arm isn't flipped the wrong direction on a sensor. That would make the corners go high and make the system fault out like your describing.
discostew is offline   Reply With Quote
Old 10-17-2017, 10:56 PM   #6
discostew
Member
 
Join Date: Sep 2010
Location: Norther Illinois
Posts: 4,034
Default Re: P38 EAS weird stuff...

If the software is trying to act like the equipment Land Rover runs for this, one of those perameters looked like it could have been distance from target height. It would make sense that all those sensors said 0. Maybe meaning 0 cm from target and that one corner was way out of range. Pull on the wires and look for coroded or almost broken wires near the sensor connectors.
discostew is offline   Reply With Quote
Old 10-19-2017, 07:44 AM   #7
JohnnoK
Almost There...
 
Join Date: Mar 2017
Location: Cape Town, South Africa
Posts: 34
Member Trucks
Default Re: P38 EAS weird stuff...

CORover,
It is the same software. I have given all the connectors I can find a squirt of contact cleaner and made sure they are well seated on reconnecting. One of the connectors in the footwell, behind the kickpanel was showing signs of growing mushrooms and there was dampness around there, so maybe I have hit on one solution.... we live in hope...

discostew,
I have made up a set of height blocks to set the various heights, and hopefully with the cleaning I have done, the next attempt will bring more joy...

Thanks for the help so far, guys!
__________________
Cheers,
John

'99 Disco II Td5
'99 P38 HSE GEMS
'75 Rover P6B 3500
'03 Aprilia Tuono RST1000
'77 Moto Guzzi LeMans 850
JohnnoK is offline   Reply With Quote
Old 12-06-2017, 06:58 PM   #8
jim-00-4.6
Keyboard Pounder II
 
jim-00-4.6's Avatar
 
Join Date: Sep 2005
Location: Genesee, CO USA
Posts: 1,856
Default Re: P38 EAS weird stuff...

You're having communications issues.
Make sure your connections are snug in the OBD port and the serial port.
Are you using a 9-pin serial port on an older machine, or a USB to serial dongle?
There's a WHOLE bunch of manual work-arounds if you can't, for whatever reason, get this fixed right away.
You can actually run the entire system with jumpers on the connector under the drivers' seat.
__________________
Jim

Do sharks complain about Monday? No.
They're up early, biting shit, chasing stuff, being scary,
reminding everyone that they are a fucking shark.
jim-00-4.6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird Stuff Happening wdmcdonald Range Rover - Technical Discussions 0 01-08-2008 07:37 PM
D1 sump seal - Right Stuff = Wrong Stuff? eliaschristeas Discovery - Technical Discussions 2 10-22-2007 11:00 AM
Weird Zoo? Mrmedia General 0 07-22-2007 04:07 PM
weird questions, hanging stuff? rjl2001 Discovery - Technical Discussions 9 12-15-2005 12:51 PM

» Log in
User Name Not a member yet?
Register Now!
Password
» Today's Birthdays
LCRover (42)
Powered by vBadvanced CMPS v3.2.3

All times are GMT -4. The time now is 07:52 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
Copyright 2000 - 2015, DiscoWeb.org. All rights reserved.

Garage Plus vBulletin Plugins by Drive Thru Online, Inc.