Clacking Sounds from ?

donniefitz2

Well-known member
Sep 15, 2020
108
42
Scottsdale, AZ
fitzventure.com
Sometimes when you fix something, you end up revealing a problem you didn't know you had. I did that once with a 30 year old A/C system. "Fixed it" but that actually broke it because it had been running wrong for so long. I don't have any answers, but, I don't think this sounds like a slipped sleeve. If anything, it's likely something on the top-end.
 

Flyfish

Well-known member
Oct 29, 2004
1,083
91
49
St. Louis
It's 5/40. I'm going to switch it to 15/40 tomorrow and see if that makes a difference. Out of curiosity why do recommend 15 over 5? I'm in Phoenix if that makes any difference in regard to temps.
You could probably run 20/50 there. I think the heavier oil is a better match to create the right hydraulic lifter resistance for the valve spring rates with moderate to warmer temps. You can even add a couple oz’s of Lucas stabilizer when you change it. I think it will make a difference.

Make sure to prefill the oil filter before you put it back on. Probably don't need to change that.
 
Last edited:

BB_Disco

Active member
Apr 26, 2021
25
0
Phoenix, AZ
You said it’s a 2004 does it have a gauge? If not you will need to plumb a pressure gauge to the oil filter housing pressure port out side. As to the oil pump gears you will need to remove the front cover housing this is where the gears are.
It's an 02. I'll have to do some research on adding the gauge. If you have any recommendations I'm open to them.
Sometimes when you fix something, you end up revealing a problem you didn't know you had. I did that once with a 30 year old A/C system. "Fixed it" but that actually broke it because it had been running wrong for so long. I don't have any answers, but, I don't think this sounds like a slipped sleeve. If anything, it's likely something on the top-end.
I totally relate in this instance. Feel like making it better made it worse, but hope to make it better again. I want to get it road-worthy so it can stop sitting in the driveway looking cool and get on the road. I'm nervous I'm damaging the car even running it with "the noise" but I may be being overcautious. Just don't want a smaller issue to turn into a new engine. Going to start with changing the oil, then the oil pressure gauge and see where that lands me. I'll report back once I get those checked off.
You could probably run 20/50 there. I think the heavier oil a better match for the hydraulic lifter resistance and valve spring rates with moderate to warmer temps. You can even add a couple oz’s of Lucas stabilizer when you change it. I think it will make a difference.

Make sure to prefill the oil filter before you put it back on. Probably don't need to change that.
I'll try adding the stabilizer too. The filter is brand new, less than 5 miles on it so I'll dump the existing oil and refill with 15/40 to start.
 

Flyfish

Well-known member
Oct 29, 2004
1,083
91
49
St. Louis
I'll try adding the stabilizer too. The filter is brand new, less than 5 miles on it so I'll dump the existing oil and refill with 15/40 to start.
Yep. Let us know.

Also, maybe someone else can chime in, but something like Ultragauge may provide oil pressure data. It provides a lot of great real-time info. That may be a solution as well as being able to monitor multiple systems.
 

boxster

Well-known member
Jun 1, 2009
182
13
Fallbrook Ca.
I saw a you tube video where a 1997 D1 owner had same valve train noise, he replaced just the rocker arms with new ones and clatter was gone!
 

discostew

Well-known member
Sep 14, 2010
6,417
497
Northern Illinois
The way you check them is by sticking a regular old pocket screwdriver into the oil feed hole, cocking it in the hole and attempting to turn the steel insert in the aluminum rocker arm. If it spins in the arm it's goimmg to make a loud ticking noise.
 

boxster

Well-known member
Jun 1, 2009
182
13
Fallbrook Ca.
The little steel inserts in the rocker arms that accept the pushrod get loose and make a pretty loud ticking noise.
The way you check them is by sticking a regular old pocket screwdriver into the oil feed hole, cocking it in the hole and attempting to turn the steel insert in the aluminum rocker arm. If it spins in the arm it's goimmg to make a loud ticking noise.
 

boxster

Well-known member
Jun 1, 2009
182
13
Fallbrook Ca.
Another idea is that when you start up the engine oil viscosity is thick however when hot it thins out and if moving parts are worn the oil won’t take up the gaps and when your in the cab with doors closed and accelerating the noise is less obvious until engine idles down.
 

boxster

Well-known member
Jun 1, 2009
182
13
Fallbrook Ca.
You said it’s a 2004 does it have a gauge? If not you will need to plumb a pressure gauge to the oil filter housing pressure port out side. As to the oil pump gears you will need to remove the front cover housing this is where the gears are.
Plumb gauge line and T into the oil sender switch port. Did you figure out you clacking noise?
 

4Runner

Well-known member
May 24, 2007
494
42
Boise Idaho
Isn’t there an capped oil port right above the oil pressure sender that you can use as well. It’s easier to pull the alternator and mounting bracket to get to it. I would run 15/40 or 20/50 on your next oil change. It’s a better fit but 5/40 isn’t going to harm anything that isn’t already on its way out. Although good advice, I don’t think it will help. Better to figure out the cause. Also if you remove the studs from your upper manifold and replace them with cap screws, you can leave your SAI system inplace when removing the upper intake. It’s frustrating at times but keep at it.
 

BB_Disco

Active member
Apr 26, 2021
25
0
Phoenix, AZ
UPDATE
I got an oil pressure gauge installed and working in the rig last night. Went with a Glowshift adapter that fits onto the filter location and has ports you can tap into. Took it for a spin but didn't write down the readings. I'm gonna drive it around again in a bit today and write down my numbers and report back.

I ended up changing out the oil to 15-40, and adding in a bottle of Lucas. I also added some Seafoam to the Oil and Gas but haven't had a chance to drive it to get it to cycle through since adding to the gas. I also got the Seafoam spray you put in the intake but haven't done that yet. Still hoping the oil pressure is the issue. I'm pretty sure I have an oil leak coming from the front cover so at some point I'll need to pull that and can get a look at the oil pump gears.

I was thinking road noise plus being over 2k RPM is drowning out the noise but with windows down in the middle of the night on a quiet street, I give it some petal and it definitely quiets down. I can't say with 100% certainty but it seems to go away under those conditions to the best of my knowledge.

What should my oil pressure readings be? Is there a proper procedure I need to follow or do I just turn her on and write down what I'm getting?
 

BB_Disco

Active member
Apr 26, 2021
25
0
Phoenix, AZ
Correction, there is no valve adjustment, and you didn’t do anything to the valve train? Another thought is stuck lifters?
Correct, I didn't do any work on the valve train. I'm going to get the oil pressure readings and then try to take off the valve cover and run it and see if anything obvious stands out.