D1 extreme oil consumption

peytondisco98

Active member
Nov 25, 2020
26
2
NYC
So, I replaced my valve cover gaskets, and now I have a disappearing oil problem that I'm trying to diagnose. It's always used a lot of oil, but never this much.

I've calculated that over 1qrt of oil is disappearing per 100 ish miles. No smoke unless I jam on the accelerator on the highway, and no oil spots on the ground. The undercarriage is not shiny and no oil in the coolant. I'm using Rotella 15w40. No ticking/knocking and the truck is running beautifully (except for guzzling all this damn oil!) I can smell it after a long highway drive.

Anyone experience anything like this? my girlfriend is sick of me popping open the hood to pour in 3qts of oil every time I get gas haha.

Thx!
 

Swedjen2

Well-known member
Sep 12, 2018
464
80
California
So, I replaced my valve cover gaskets, and now I have a disappearing oil problem that I'm trying to diagnose. It's always used a lot of oil, but never this much.

I've calculated that over 1qrt of oil is disappearing per 100 ish miles. No smoke unless I jam on the accelerator on the highway, and no oil spots on the ground. The undercarriage is not shiny and no oil in the coolant. I'm using Rotella 15w40. No ticking/knocking and the truck is running beautifully (except for guzzling all this damn oil!) I can smell it after a long highway drive.

Anyone experience anything like this? my girlfriend is sick of me popping open the hood to pour in 3qts of oil every time I get gas haha.

Thx!
Why, you're an ol and gas man!
 

peytondisco98

Active member
Nov 25, 2020
26
2
NYC
Here is a pic of the passenger side PVC valve cover. Could this be the culprit? Anyone know where I can get a replacement as I could not seem to find one on Atlantic British. Or could I just drill through? Also, I noticed there is no valve cover on the driver's side, and it goes directly into the throttle body, which is confusing.

Pic of Passenger side:
passenger side PVC valve cover.jpg

Pic of driver's side:
Driver's side PVC.jpg
 

Blueboy

Well-known member
Apr 20, 2004
2,429
156
Back in the USA; Rockwood, PA
Here is a pic of the passenger side PVC valve cover. Could this be the culprit? Anyone know where I can get a replacement as I could not seem to find one on Atlantic British. Or could I just drill through? Also, I noticed there is no valve cover on the driver's side, and it goes directly into the throttle body, which is confusing.

Pic of Passenger side:
View attachment 60474

Pic of driver's side:
View attachment 60475
Try Will Tillery or Rovers North.