Fixed the SAI P0413 Code - But the P1590 Bumpy Road Code showed up

bendts

Well-known member
Jan 27, 2015
277
17
Farmland
I had the P0413 Code for years as I removed the SAI System - (Secondary Air Injection System Switching Valve 'A' Circuit Open) - So today i cut the connector wires and installed a standard 20 amp relay - This got rid of the CEL that the P0413 code was causing - Finally.

But as soon as I fixed this, the P1590 code showed up - DTC P1590-P1592: ABS - ROUGH ROAD SIGNAL CIRCUIT MALFUNCTION

I have had the 3 Amigos on for quite a while and replaced the Drivers Front Hub last fall, but have yet to go get the 3 amigo codes reset. But have never had this code pop up until today.

Has this just been sitting in the deep bowels of the computer sys? Or is this a new fault? It came on while I was still parked in the garage... No other codes are showing on the reader.
 

discostew

Well-known member
Sep 14, 2010
6,503
525
Northern Illinois
You wouldn't have gotten a rough road signal with wheel speed sensor faults stored. So yes it was probably laying in there. I'm not sure what your going to find with that one, maybe a poor connection or shorted wire?
The system monitors wheel speed signals and when it knows your on a rough road it tells the ECM to ignore misfire data. It does this because rolling the wheel down into a pothole and back out the other side of it will cause the crankshaft to decelorate. Thats how the engine knows it just misfired, by monitoring the crank position sensor for any deceloration.
 

bendts

Well-known member
Jan 27, 2015
277
17
Farmland
Only thing I can think of is there are some seriously bad Bridge Joints going into & out of Minneapolis (esp when is cold) - so may have hit one of those just right @65.
 

rovercanus

Well-known member
Apr 24, 2004
9,485
158
P1590 regularly pops up with abs faults. Reset your abs and cel and you should be fine.