Stuck open rear sunroof

MNTundra

Member
Feb 2, 2020
16
3
Minnesota
My rear sunroof is stuck in the tilt mode. No motor signal I’ll have to replace the motor sometime soon. I’ve tried to use the manual operation with an Allen key but that this is hard as a rock. Do you guys recommend to use a drill attachment on it or will it break? It seems like it needs a lot of torque. I just want to get it closed for now. Thank you!

0C3EB3FC-9D4F-4B57-BCB2-38A64DD7E096.jpeg
09A48479-591B-4B60-A398-7CB5BD3D7ED6.jpeg
81C0908C-60C4-4D2B-A99D-04E05514114F.jpeg
 

nashvegas

Member
Feb 12, 2009
12
3
Just went thru this (albeit with D2, but same mechanisms).

What I would do is remove the motor/drop it down so that it's not connected to the drive cables (it has a little gear on top of the motor), then climb up top and PUSH the sunroof back in place, then reconnect the motor so it stays shut. Don't push too hard as you may screw tracks up, but on mine the motor was frozen solid -- the tracks still moved. They just wouldn't move with the motor gear engaged.
 

nashvegas

Member
Feb 12, 2009
12
3
(in other words rather than trying to do it thru the motor w/ a stronger drill or bigger hex wrench, if it's stuck, try doing it with the motor unattached)
 

MNTundra

Member
Feb 2, 2020
16
3
Minnesota
Thank you for your suggestion it really helped me out! I finally had time to fix this issues. What I did was took the headliner down in the rear portion of the car and then I took out the motor. I tired pushing on it but nothing budged. So I decided to break down the motor and see what was the issues. Heres my progress so far.E72ACFF9-0C01-46FB-BAD5-DCE74C774B25.jpeg
84E25E5B-CF31-4FF3-AF67-AB24926FCDE3.jpeg
Cracking into the motor wasn’t that bad until I hit the magnet portion of it so I had to use and vice and really tug on it to get it out. There must’ve been a bunch of gunk and other crap in the motor it was a mess. So I decided to clean it.99EC550A-3BAC-4CC1-8867-3DD302961ECB.jpeg
ECF20637-2267-42D6-9479-A6391172E3F3.jpeg
D8035DEA-3951-4DC0-A4D9-E50F9D0BA1A3.jpegAfter a deep clean of all the components using WD40 and electrical cleaner I finally got it sparkling! The magnet circuit couldn’t even budge with all the gunk in it. So I put it back in and Boom! Functioning sunroof again! Thanks again for the advice!