Stall (Every Few Minutes) Starts (After Few Minutes Waiting)

ROVR GURL

Member
Jul 12, 2020
23
0
LA, CA
Hi all! I have a gurl friend that's having problems with her "99 D2. It stalls every few minutes. It's weird, 'cause it will start back up after waiting for a few minutes. All lights and vehicle thingys work, including the A/C, windows, radio, etc., and not one warning light. Over half a tank of gas, it doesn't matter if its sitting parked and running or driving, it will just stall/shut off. But, everything else seems to work. What Gives???
Do you have any fault/trouble codes?

Sounds like the crankshaft position sensor on the LH side of the engine is crapping out.
Buy a Bosch #ERR-7354 or Echlin #CSS9280 (supposedly a Bosch brand in NAPA box).
Hats of to JUKE179r and all the gang :cool: ! It's the CRANK CASE POSITION SENSOR ! ! !

She took it down to 11 Street Auto Repair (A family owned 'Cisco all things Land Rover shop of POLISH heritage).
She got an ESTIMATE of one hour LABOR + PART for the CPS and Voila, she was once again driving happily down the road that same day ! ! ! :)
 

ROVR GURL

Member
Jul 12, 2020
23
0
LA, CA
Hats of to JUKE179r and all the gang :cool: ! It's the CRANK CASE POSITION SENSOR ! ! !

She took it down to 11 Street Auto Repair (A family owned 'Cisco all things Land Rover shop of POLISH heritage).
She got an ESTIMATE of one hour LABOR + PART for the CPS and Voila, she was once again driving happily down the road that same day ! ! ! :)


IT FAILD AGAIN ! : - 0

Two days of driving great it returned to the same problem!
 
  • Sad
Reactions: Jimmy

JUKE179r

Well-known member
Sep 14, 2016
508
44
Suffolk, UK
Make sure they installed a BOSCH brand CPK and not a Duralast. I've been told sometimes a Bosch CPK is in a Duralast box. :confused:
I had 2 Duralasts that crapped out on me with in a 3 weeks time. One CPK failed right out the box and the other made my engine rev up while I had it in Drive. Luckily had my foot on the brake each of the 6 times it happened at a stop light/sign. Weird...
 

ROVR GURL

Member
Jul 12, 2020
23
0
LA, CA
Make sure they installed a BOSCH brand CPK and not a Duralast. I've been told sometimes a Bosch CPK is in a Duralast box. :confused:
I had 2 Duralasts that crapped out on me with in a 3 weeks time. One CPK failed right out the box and the other made my engine rev up while I had it in Drive. Luckily had my foot on the brake each of the 6 times it happened at a stop light/sign. Weird...
Thanks again, I will pass it on to her. :)

o_O Wow! I had know idea parts can be vastly different in quality? :eek:
 

ROVR GURL

Member
Jul 12, 2020
23
0
LA, CA
Thanks again, I will pass it on to her. :)

o_O Wow! I had know idea parts can be vastly different in quality? :eek:
-->UPDATE <--

1. Parts have been verified to be authentic Bosch.
2. Driver side fuse box replaced. (Mechanic reported these to be historically problematic)
3. Apparently component testing is not possible for sensor or fuse box other than remove and replace (RNR)

Vehicle running strong two days now. Will keep posted with fingers crossed for her :)
 
Last edited:

Lake_Bueller

Well-known member
Aug 11, 2004
2,001
38
53
Beloit, WI
I'm late to the party. But I had horrible stall issues with my G4 AFTER replacing the CKp. I replaced it as "preventative maintenance" when they had the engine halfway torn apart for headgaskets. They finally replaced the plug and all the wires going back to the fuse box inside the passenger footwell.

Still don't know where in the line there was a problem. But so far so good (fingers crossed)
 

Rmcripe

Member
Sep 8, 2019
18
2
Grand Rapids MI
I recently had a similar issue that was diagnosed as a crank sensor had it replaced & 2 days later did the same thing. It was actually an issue wiring, replaced that and it’s been running strong for 3 weeks now without any issue.