The joys of being a new D2 owner - help!

ezzzzzzz

Well-known member
Apr 22, 2010
590
3
SE Va
Buying a Land Rover is a great idea....until it isn't. There has to be a mental illness that has yet to be named for this. Two types of LR owners can be found. Both want the persona and 'status' of ownership. The first can't fix a lawnmower but jump in enthusiastically and learn through trial by fire. Then we have those seasoned and proficient owners that, despite the cost and frustrations, continue to buy these spawns of Satan. Having owned over 30 of these trucks (presently down to 6) I guess I fall into that latter group.
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
I did the b mod to the shuttle valve today. took 1.5 hrs to do start to finish.
drove away, firstpot hole i hit on the road and 3 amigos plus parking brake light on. wtf!!!!

read the codes. at least its a new one. 66 - front left sensor

..--Previous Faults--->
Active Faults:
066:Front Left sensor electric fail
Logged Faults:
066:Front Left sensor electric fail
<-END Fault

my brakes ARE squealing, but i don't know if its front or back or both. i have new rear pads going on tomorrow. ill also clean/service the front brakes, and pull and inspect/clean the front left sensor, and bleed the brake system. if the sensor its chewed up ill order a new hub. if it looks ok ill order a new sensor. ill also get new front brake pads if still squealing after the rears are replaced.

ya think that'll be the end of my problems?! lol
 

pdogg

Well-known member
Jul 18, 2005
1,203
24
Phoenix, AZ
Does your truck happen to have a lift with ABS line extensions? these connections can drive you nuts and give you wheel sensor faults, where it's just an electric connector issue.
 

SGaynor

Well-known member
Dec 6, 2006
7,146
161
50
Bristol, TN
I did the b mod to the shuttle valve today. took 1.5 hrs to do start to finish.
drove away, firstpot hole i hit on the road and 3 amigos plus parking brake light on. wtf!!!!

read the codes. at least its a new one. 66 - front left sensor

..--Previous Faults--->
Active Faults:
066:Front Left sensor electric fail
Logged Faults:
066:Front Left sensor electric fail
<-END Fault

my brakes ARE squealing, but i don't know if its front or back or both. i have new rear pads going on tomorrow. ill also clean/service the front brakes, and pull and inspect/clean the front left sensor, and bleed the brake system. if the sensor its chewed up ill order a new hub. if it looks ok ill order a new sensor. ill also get new front brake pads if still squealing after the rears are replaced.

ya think that'll be the end of my problems?! lol

If your front left brake is squealing, that's probably the problem. Check the pads/caliper and replace as necessary (rotors too, if those are chewed up).

Also, check your new electrical connections on your ABS mod wiring - especially the grounds. I did the modification and 6 month later the 3 amigos came back. Turned out to be the connection on the mod to ground (the chassis) came undone from the crimp. Redid it and haven't had a problem in 5+ years.
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
thanks for the advice.. its has a 2" terrafrima lift in the truck before i bought it. not sure about the extensions.. ill look into that this evening when im in there.
 

pdogg

Well-known member
Jul 18, 2005
1,203
24
Phoenix, AZ
that's cool.. I've seen some of our local clubs D2's have that issue, wires replaced all the way back to the SLABS ECU..
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
abs, about 4" from the sensor. seemed to be hitting the backside of the tire and was abraised through. i tied it saftely out of the way now. there was no extension piece in that i could see
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
I did about 100 miles today on gravel roads. Not one dash light or code came up!!
I still have not received my new gas cap or tstat.
I cleaned the existing gas cap and filler area well today and clicked it on tight about 20 times. No Evap codes yet. Im confident it ls the fuel cap. If the code comes on repeatedly, it stops when I re-tighten the cap for a few days.
My brakes were squeaking after my rear brake job, so new front rotors and pads are on order. Ebc slotted rotors and Akebono pads
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
hehe, 2 days in a row no dash lights!

However,
i decided to order a new waterpump today. ill throw that in with the thermostat this week if its here on time. with the engine running so much cooler in low range gears and high rpms, im convinced my high(er) temps are also due to low volume water flow.
my driver a-piller trim also came loose. so i ordered new clips and rivets to reattach it.
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
i got the new water thermostat in tonight.
before temps:
idling - 212-215
coast down hill - 203-205
average driving - 217-221

after temps:
idling - 190-195
coast down hill - 183-186
average driving - 188-195

thats a huge improvement imo..
FYI it was a motorad thermostat that WAS in the car, now its genuine. i dont know what the temperature of motorad in the car was though. car seems to run alot quieter and smoother -or atleast that's what im telling myself.
 

Howski

Well-known member
Oct 19, 2009
1,264
121
Alabama
Those temps are much better. That’s about dead on what temps mine runs with the genuine 180
 

SafariDave

Well-known member
Sep 14, 2008
92
0
Brooklyn, NYC
Alright.. update.

abs amigo reader arrived. shuttle valve is the culprit. will be doing the "b" mod to it in the next couple weeks once some other things are done.

-new rad arrived today
-viscous fan clutch seemed strong via. the rolled-up paper test. will not replace at this time.
-new akebono rear brakes arrived, will put in and bleed system with the shuttle valve mod.
-new coolant tank lid put on yesterday
-returned motorad low temp thermostat, ordered genuine low temp and fuel tank cap from lucky 8 with express shipping.
-new front drive shaft should arrive thursday.

looks like ill have a busy saturday! also, heres some pics of last weekend.
I like the front bumper where is it from? who makes it?
Dave
 

nedarb2

Active member
Apr 28, 2018
42
2
canada
I’m not sure, look on their website.


My front output shaft seal (transfer case) started puking oil out today all over exhaust. Makes for a stinky ride. New flange seal kit on order.
 

SafariDave

Well-known member
Sep 14, 2008
92
0
Brooklyn, NYC
The 1999 D2 I acquired last April had old thermostat was running at 212F when idling after a long drive with AC on. I switched to the 180F thermostat. On Highway 40-65mph temps are 186-188, Slow traffic 15/30 mph 190-193F, Idel after long drive with AC on Stopped on a Red Light 195-198F. (I believe Rad, Water Pump & Vis Fan are original.)
Dave
 

SafariDave

Well-known member
Sep 14, 2008
92
0
Brooklyn, NYC
I replaced the Thermostat on the D2 I acquired last April to the 180F. The temps now are; Highway speeds 40-65mph 186-188F, Slow roads stop and go 15-30mph 190-193F, Stopped at a red light idling or parked 195-198F with AC on or off.
Dave